Rear Wiper and Washer problems

Hey guys I’m Hamish, owner of a 1991 GTO here in New Zealand. The rear wiper blade does not move and neither do the cleaning fluid sprayers when I turn on either of them. Front Wiper blades do work as well as the washers (no liquid comes through though as my front fluid reservoir has a leak which I can fix). I am yet to check the fuses to see if anything has blown, but should I find that all of them are functioning I am unsure where to go next.
The Fluid reservoir for the rear washer is full but I do not hear a pumping/mechanical sound when I try to use them (the same pumping sound I hear from the front washers). And the rear wiper simply does not move.
Browsing the YouTube Channel I could not see any video detailing the rear wiper/washer mechanism
and/or wiring, but if there is one out there it would be appreciated.

For the rear wiper fluid pump: It is located on the rearmost interior wall of the trunk, you need to take you the back interior panel to access it, and the right hand side interior panel as well if you want to get to the tube going up to the sprayer. Its pretty easy to check, my first suggestion would be to check the contacts since they might be corroded/rusted.

For the rear wiper: Mine didn’t work when I first got my '91 SL, so I removed the interior panel on the hatch and found an enormous amount of rust. My whole motor was so rusted that I couldn’t even find the screws to take it apart, so I just trashed it and got a “new” one out of a junkyard.

Joe has videos on the removal of all the interior pieces I mentioned. I would suggest checking the contacts on both motor harnesses using a multimeter as a first step.

Good luck,

1 Like

Super helpful thanks, will update any new information that comes through.

If it hasn’t been used in a long time the pump may have seized. You should be able to partially disassemble it and free it up.

I realize this post is several months old but the first thing I’d check is the switch itself. They are notorious for failing. You may find that the switch has been unplugged because it’s broken and the wiper would be stuck on.

1 Like

My 92’ has a rear wiper that gets stuck on so I unplugged it lol.

The first time I pressed the switch it turned the wiper on but then they wouldn’t shut off.

Does replacing the switch by the steering wheel fix this? Or is their some sort of relay that’s not shutting off? Thanks

The switch fails. You can technically fix the switch. What happens is the tab to the switch rotates on breaks, and it causes the switch to stick on. You can super glue the tab back on and it will work like new.

Mine failed earlier this year. I actually ended up buying a new OEM one, as well as one off eBay, and while replacing the switch I saw the broken tab and tried the super glue and it worked like it should.