Car won't rev up properly / rough but has an OK idle

Hi all.

So I did a bottom end rebuild (replaced bearings) on the car (gen 1 twin turbo GTO)

The problem seems odd, it appears to idle fine, however it does have a small stumble but not much, its got a stable idle over all.

Now when I try to rev the car it’ll bog down then rev up but its not smooth, it doesn’t sound or feel like its missing, just feels rough.

The engine did come out and has gone back in, Before the bearing issue the engine ran perfectly fine.

What I have tried so far:

*Taken all intake (cold side and boost side) pipe work off, checked and put back together(I have done this now at least 6 times so confident its not an air leak)
*I have taken off all vacuum hoses and re-installed them according to both the reference photos I took before i removed engine & the diagram on the bonnet, again I am very confident they are all correct.
*checked the MAF sensor and this is ok
*checked TPS this is ok
*checked the CAS this is okay and in time
*checked cam belt timing this is in time
*checked spark plugs(recently had all new)
*injectors where refurbished just before teardown
*checked both FPR and boost solenoids and are actuating fine
*checked FPR and this is working fine
*checked fuel pump/pressure this is fine
*its had new PTU & coils just before engine build
*ECU was rebuilt by ECU doctor
*checked all wires and plugs at least 20 times
*removed plenum checked gaskets and resealed everything

I have just ordered a hand held halo scanner to hopefully help but in the meantime…any ideas at all?

here is a video of the sound it makes

I would suspect the “refurbed injectors before tear down” as it doesn’t sound like it’s firing on all cylinders imho. Start with the best diagnostic you can get before stripping it down again. Just my thoughts

The car ran well (prior to the bearing spinning) with these injectors, nothing has been changed since, so i would be fairly confident the injectors haven’t failed.

The injectors wasn’t taken out of the top end so really no reason for them to fail surely?

1 Like

update, tried new coil pack - no difference

on Sunday I had a member of one of the forums come help me with some spare parts from his known good running car.

While he was down he brought his vacuum tester and all checked out good.

He let me try his, MAF, ECU, Coil pack / PTU, we also doubled checked ignition timing with a timing light, this was correct we put new plugs in and resealed everything.

Still got the hesitation.

Now, since changing the coils one upside is under acceleration it seems to pull now, but still has very poor throttle response and bogging.

Consider stale petrol or crook battery? You can sometimes think the worst with so many electronics, but mine did something similar post rebuild (many months). Idled fine but coughed and spluttered on revving, even the tacho went crazy like it was broken or something seriously electrical going on. I threw in some fresh 100 octane, charged the battery and it ran like a champ.

Its had a brand new battery, fuel im confident is good as I took a sample and it seems fine. its not that old.

still no joy unfortunately

Any progress ? Would like to know how you solved this.

Sorry I missed this notification, yes I did it turned out to be an injector that had failed open so lost all rail pressure!